読者です 読者をやめる 読者になる 読者になる

It's raining cats and dogs.

無駄なことなんてないはず

Application does not specify an API level requirement! Device API version is 10 っていうwarningが出てる

android

Application does not specify an API level requirement!
Device API version is 10

適当なandroid project つくってエミュレータで実行してみたら、eclipseのコンソールに↑のwarningが出てたので、warningだから別にいいけど、気持ち悪いのでググった。
http://d.hatena.ne.jp/hasuie/20091020/1256038188
ということらしい。
androidのバージョンに合わせて、Device APIってののバージョンをマニフェストファイルで指定する必要があるらしい。
上の例だとバージョンを10にするとか。

<?xml version="1.0" encoding="utf-8"?>
<manifest xmlns:android="http://schemas.android.com/apk/res/android"
      package="org.example.hello"
      android:versionCode="1"
      android:versionName="1.0">
    <uses-sdk android:minSdkVersion="10"></uses-sdk> <!-- ←追加 -->
    ...
    </application>
</manifest>

な感じで追加したら、warningでなくなった。